Top
SVERWEIS – Suchen und finden – RonnyDee´s Blog
fade
5638
post-template-default,single,single-post,postid-5638,single-format-standard,eltd-core-1.1.1,flow child-child-ver-1.0.0,flow-ver-1.3.7,eltd-smooth-scroll,eltd-smooth-page-transitions,ajax,eltd-blog-installed,page-template-blog-standard,eltd-header-standard,eltd-fixed-on-scroll,eltd-default-mobile-header,eltd-sticky-up-mobile-header,eltd-dropdown-default,wpb-js-composer js-comp-ver-5.2.1,vc_responsive

SVERWEIS – Suchen und finden

Die SVERWEIS Funktion in Excel kann einem dann behilflich sein, wenn man zwei Tabellen matchen, vergleichen oder miteinander ergänzen möchte. Dabei kann nach einen Suchkriterium gesucht und in der jeweiligen Tabelle alle Spalten die sich rechts davon befinden, ausgegeben werden. Wichtig: Befindet sich dein Suchkriterium in der Mitte einer Tabelle, so können mittels SVERWEIS keine Spalten die sich links davon befinden, ausgegeben werden!

|

|

In der ersten Tabelle A1 bis B8 befinden sich Daten von Mitarbeitern, deren Vorname und PLZ bekannt ist. Nun möchte man aber auch wissen, welche Stadt (oder auch Bundesland) sich hinter den PLZ befindet. Deshalb gibt es eine zweite Tabelle mit den jeweiligen Informationen. Es empfiehlt sich aus Performancegründen, dass sich diese Tabelle im selben XLS Dokument (als weitere Registerkarte) befindet.

|

In der zweiten Tabelle befinden sich die Informationen von A1 bis C8, das ist unsere Matrix.

|

Was macht die Funktion SVERWEIS?

Um nun in der ersten Tabelle den Ort in Spalte C zu ergänzen, hilft uns die Funktion SVERWEIS.
Also kann man in Tabelle1 C2 folgende Funktion hinterlegen: =SVERWEIS(B2;Tabelle2!A:C;2;FALSCH)

|

Warum?
Weil man durch diese Funktion Excel mitteilt, dass man das Feld B2 (8010) mit der Matrix unter Tabelle2!A:C (also unsere Matrix) vergleichen soll und die zweite Spalte (2), in unserem Fall den Ort, ausgeben soll. Allerdings nur wenn es eine genaue Übereinstimmung (FALSCH) gibt.

|

Somit habe ich soeben die Formel „=SVERWEIS(B2;Tabelle2!A:C;2;FALSCH)“ entschlüsselt.

|

Die Formel kann übrigens auf jede beliebige Zeile darunter angewendet werden. Es ändert sich somit nur der Bezug von B2 auf z.B. B3 oder B4 usw.

|

Folgendes gilt es zu beachten:

  1. Die Matrix (in diesem Beispiel Tabelle2!A:C muss IMMER die Spalte beinhalten die die benötigten Suchkriterien beinhaltet, sprich WAS sucht man eigentlich UND die Spalte beinhalten die man dann ermitteln möchte, sprich WAS möchte ich dann ermitteln/ausgeben
    |
  2. Jene Spalten die ich ermitteln/ausgeben möchte MÜSSEN rechts von der Spalte der Suchkriterien vorhanden sein. SVERWEIS kann nicht nach links lesen, sondern stets nur nach rechts
    |
  3. Mit der 3. Option der SVERWEIS Funktion (in diesem Fall „2“) gibt man an, welche Spalte man ermitteln/ausgeben möchte. Dabei zählt man einfach die Spalten nach rechts, einschließlich der Suchspalte. In diesem Fall ist unsere Suchspalte, die Spalte A und wir möchten den Ort wissen (Spalte B) = Spalte A + Spalte B = 2
    Möchten wir anstatt dem Ort das Bundesland ausgeben (Spalte C), dann wäre der Wert: Spalte A + Spalte B + Spalte C = 3

Post a Comment